#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?i)^(\w*?)(\w+?)(\w*);(\2)$"
Local $sString = "castellan;STELLA" & @CRLF & _
"castellan;TELL" & @CRLF & _
"castellan;ELLA" & @CRLF & _
"castellan;STELL" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1$4$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)