$re = '/(?i)^(\w*?)(\w+?)(\w*);(\2)$/m';
$str = 'castellan;STELLA
castellan;TELL
castellan;ELLA
castellan;STELL
';
$subst = "$1$4$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;