re = /(?i)^(\w*?)(\w+?)(\w*);(\2)$/m
str = 'castellan;STELLA
castellan;TELL
castellan;ELLA
castellan;STELL
'
subst = '$1$4$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result