const regex = /(?i)^(\w*?)(\w+?)(\w*);(\2)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)^(\\w*?)(\\w+?)(\\w*);(\\2)$', 'gm')
const str = `castellan;STELLA
castellan;TELL
castellan;ELLA
castellan;STELL
`;
const subst = `$1$4$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);