import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(\\w*?)(\\w+?)(\\w*);(\\2)$";
final String string = "castellan;STELLA\n"
+ "castellan;TELL\n"
+ "castellan;ELLA\n"
+ "castellan;STELL\n\n";
final String subst = "$1$4$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}