use strict;
my $str = 'castellan;STELLA
castellan;TELL
castellan;ELLA
castellan;STELL
';
my $regex = qr/(?i)^(\w*?)(\w+?)(\w*);(\2)$/mp;
my $subst = '$1$4$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";