import Foundation
let pattern = #"(?i)^(\w*?)(\w+?)(\w*);(\2)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
castellan;STELLA
castellan;TELL
castellan;ELLA
castellan;STELL
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$4$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)