using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\/(.*)\/([a-z]*)|.*)$";
string input = @"/^[0-9]+$/
/^(true|false)$/i
/^\\d{4}-\\d{2}-\\d{2}$/
/^\\d{4}-\\d{2}-\\d{2}T\\d{2}:\\d{2}$/i
yyyy-mm-ddThh:mm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}