package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\/(.*)\/([a-z]*)|.*)$`)
var str = `/^[0-9]+$/
/^(true|false)$/i
/^\\d{4}-\\d{2}-\\d{2}$/
/^\\d{4}-\\d{2}-\\d{2}T\\d{2}:\\d{2}$/i
yyyy-mm-ddThh:mm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}