re = /^(?:\/(.*)\/([a-z]*)|.*)$/m
str = '/^[0-9]+$/
/^(true|false)$/i
/^\\\\d{4}-\\\\d{2}-\\\\d{2}$/
/^\\\\d{4}-\\\\d{2}-\\\\d{2}T\\\\d{2}:\\\\d{2}$/i
yyyy-mm-ddThh:mm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end