const regex = /^(?:\/(.*)\/([a-z]*)|.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\\/(.*)\\\/([a-z]*)|.*)$', 'gm')
const str = `/^[0-9]+\$/
/^(true|false)\$/i
/^\\\\d{4}-\\\\d{2}-\\\\d{2}\$/
/^\\\\d{4}-\\\\d{2}-\\\\d{2}T\\\\d{2}:\\\\d{2}\$/i
yyyy-mm-ddThh:mm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}