$re = '/^(?:\/(.*)\/([a-z]*)|.*)$/m';
$str = '/^[0-9]+$/
/^(true|false)$/i
/^\\\\d{4}-\\\\d{2}-\\\\d{2}$/
/^\\\\d{4}-\\\\d{2}-\\\\d{2}T\\\\d{2}:\\\\d{2}$/i
yyyy-mm-ddThh:mm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);