import Foundation
let pattern = #"^(?:\/(.*)\/([a-z]*)|.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/^[0-9]+$/
/^(true|false)$/i
/^\\d{4}-\\d{2}-\\d{2}$/
/^\\d{4}-\\d{2}-\\d{2}T\\d{2}:\\d{2}$/i
yyyy-mm-ddThh:mm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)