#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^+84](((09)\d{8})|((9)\d{8})|((1)\d{9}))|(\+?((84)(\d{9,10}))))"
Local $sString = "84944123123" & @CRLF & _
"84344123123" & @CRLF & _
"912321321" & @CRLF & _
"0912888111" & @CRLF & _
"+84913222333" & @CRLF & _
"841235333222" & @CRLF & _
"+841234222222" & @CRLF & _
"1234441111" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"+8412342222222" & @CRLF & _
"" & @CRLF & _
"(\+?((84)(\d{9,10})))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")