use strict;
my $str = '84944123123
84344123123
912321321
0912888111
+84913222333
841235333222
+841234222222
1234441111
+8412342222222
(\\+?((84)(\\d{9,10})))';
my $regex = qr/([^+84](((09)\d{8})|((9)\d{8})|((1)\d{9}))|(\+?((84)(\d{9,10}))))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}