const regex = /([^+84](((09)\d{8})|((9)\d{8})|((1)\d{9}))|(\+?((84)(\d{9,10}))))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^+84](((09)\\d{8})|((9)\\d{8})|((1)\\d{9}))|(\\+?((84)(\\d{9,10}))))', 'gm')
const str = `84944123123
84344123123
912321321
0912888111
+84913222333
841235333222
+841234222222
1234441111
+8412342222222
(\\+?((84)(\\d{9,10})))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}