# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^+84](((09)\d{8})|((9)\d{8})|((1)\d{9}))|(\+?((84)(\d{9,10}))))"
test_str = ("84944123123\n"
"84344123123\n"
"912321321\n"
"0912888111\n"
"+84913222333\n"
"841235333222\n"
"+841234222222\n"
"1234441111\n\n\n"
"+8412342222222\n\n"
"(\\+?((84)(\\d{9,10})))")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.