$re = '/([^+84](((09)\d{8})|((9)\d{8})|((1)\d{9}))|(\+?((84)(\d{9,10}))))/m';
$str = '84944123123
84344123123
912321321
0912888111
+84913222333
841235333222
+841234222222
1234441111
+8412342222222
(\\+?((84)(\\d{9,10})))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);