import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^+84](((09)\\d{8})|((9)\\d{8})|((1)\\d{9}))|(\\+?((84)(\\d{9,10}))))";
final String string = "84944123123\n"
+ "84344123123\n"
+ "912321321\n"
+ "0912888111\n"
+ "+84913222333\n"
+ "841235333222\n"
+ "+841234222222\n"
+ "1234441111\n\n\n"
+ "+8412342222222\n\n"
+ "(\\+?((84)(\\d{9,10})))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}