package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^+84](((09)\d{8})|((9)\d{8})|((1)\d{9}))|(\+?((84)(\d{9,10}))))`)
var str = `84944123123
84344123123
912321321
0912888111
+84913222333
841235333222
+841234222222
1234441111
+8412342222222
(\+?((84)(\d{9,10})))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}