using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)test\.(\S+)";
string input = @"SHOULD WORK -> test.something test.somethingelse.another // 2 Matches This is correct
SHOULD NOT WORK -> one.test.two // 1 mathces should be 0 is not the start of word
SHOULD NOT WORK -> ""test.shouldnotbeselected 'test.something //2 matches should be 0 has ' or ""
NEGATIVE LOOK AHEAD WORKS WITH ""i"" and not with quoutes I don't know why ->
itest.doesnottake 'test.doesnottake ""test.doesnottake // 2Matches should be 0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}