# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)test\.(\S+)"
test_str = ("SHOULD WORK -> test.something test.somethingelse.another // 2 Matches This is correct\n\n"
"SHOULD NOT WORK -> one.test.two // 1 mathces should be 0 is not the start of word\n\n"
"SHOULD NOT WORK -> \"test.shouldnotbeselected 'test.something //2 matches should be 0 has ' or \"\n\n"
"NEGATIVE LOOK AHEAD WORKS WITH \"i\" and not with quoutes I don't know why -> \n"
"itest.doesnottake 'test.doesnottake \"test.doesnottake // 2Matches should be 0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.