import Foundation
let pattern = #"(?<!\S)test\.(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SHOULD WORK -> test.something test.somethingelse.another // 2 Matches This is correct
SHOULD NOT WORK -> one.test.two // 1 mathces should be 0 is not the start of word
SHOULD NOT WORK -> "test.shouldnotbeselected 'test.something //2 matches should be 0 has ' or "
NEGATIVE LOOK AHEAD WORKS WITH "i" and not with quoutes I don't know why ->
itest.doesnottake 'test.doesnottake "test.doesnottake // 2Matches should be 0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)