$re = '/(?<!\S)test\.(\S+)/m';
$str = 'SHOULD WORK -> test.something test.somethingelse.another // 2 Matches This is correct
SHOULD NOT WORK -> one.test.two // 1 mathces should be 0 is not the start of word
SHOULD NOT WORK -> "test.shouldnotbeselected \'test.something //2 matches should be 0 has \' or "
NEGATIVE LOOK AHEAD WORKS WITH "i" and not with quoutes I don\'t know why ->
itest.doesnottake \'test.doesnottake "test.doesnottake // 2Matches should be 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);