const regex = /(?<!\S)test\.(\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)test\\.(\\S+)', 'gm')
const str = `SHOULD WORK -> test.something test.somethingelse.another // 2 Matches This is correct
SHOULD NOT WORK -> one.test.two // 1 mathces should be 0 is not the start of word
SHOULD NOT WORK -> "test.shouldnotbeselected 'test.something //2 matches should be 0 has ' or "
NEGATIVE LOOK AHEAD WORKS WITH "i" and not with quoutes I don't know why ->
itest.doesnottake 'test.doesnottake "test.doesnottake // 2Matches should be 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}