import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)test\\.(\\S+)";
final String string = "SHOULD WORK -> test.something test.somethingelse.another // 2 Matches This is correct\n\n"
+ "SHOULD NOT WORK -> one.test.two // 1 mathces should be 0 is not the start of word\n\n"
+ "SHOULD NOT WORK -> \"test.shouldnotbeselected 'test.something //2 matches should be 0 has ' or \"\n\n"
+ "NEGATIVE LOOK AHEAD WORKS WITH \"i\" and not with quoutes I don't know why -> \n"
+ "itest.doesnottake 'test.doesnottake \"test.doesnottake // 2Matches should be 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}