use strict;
my $str = 'SHOULD WORK -> test.something test.somethingelse.another // 2 Matches This is correct
SHOULD NOT WORK -> one.test.two // 1 mathces should be 0 is not the start of word
SHOULD NOT WORK -> "test.shouldnotbeselected \'test.something //2 matches should be 0 has \' or "
NEGATIVE LOOK AHEAD WORKS WITH "i" and not with quoutes I don\'t know why ->
itest.doesnottake \'test.doesnottake "test.doesnottake // 2Matches should be 0';
my $regex = qr/(?<!\S)test\.(\S+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}