# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*(?=;)).*/$1/gm;t' <<< "текст1;текст2;текст3
текст1;текст2
текст1;текст2;текст3;текст4
текст1;текст2;текст3;текст4;текст5"