using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*(?=;)).*";
string substitution = @"$1";
string input = @"текст1;текст2;текст3
текст1;текст2
текст1;текст2;текст3;текст4
текст1;текст2;текст3;текст4;текст5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}