import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*(?=;)).*";
final String string = "текст1;текст2;текст3\n"
+ "текст1;текст2\n"
+ "текст1;текст2;текст3;текст4\n"
+ "текст1;текст2;текст3;текст4;текст5";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}