use strict;
my $str = 'текст1;текст2;текст3
текст1;текст2
текст1;текст2;текст3;текст4
текст1;текст2;текст3;текст4;текст5';
my $regex = qr/(.*(?=;)).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";