#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*(?=;)).*"
Local $sString = "текст1;текст2;текст3" & @CRLF & _
"текст1;текст2" & @CRLF & _
"текст1;текст2;текст3;текст4" & @CRLF & _
"текст1;текст2;текст3;текст4;текст5"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)