const regex = /(.*(?=;)).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*(?=;)).*', 'gm')
const str = `текст1;текст2;текст3
текст1;текст2
текст1;текст2;текст3;текст4
текст1;текст2;текст3;текст4;текст5`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);