re = /(.*(?=;)).*/m
str = 'текст1;текст2;текст3
текст1;текст2
текст1;текст2;текст3;текст4
текст1;текст2;текст3;текст4;текст5'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result