#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<hora>[0-9]{8})\s(?<mix>\d{3})(?<resp>[I|O])"
Local $sString = " 09523744 865O F010@@@@Y1905A46100000002 00000000151100157600STD20001" & @CRLF & _
" 865O 030202040005 1029 003047100000000012602 " & @CRLF & _
" 865O 00000000000000000000000000000000000000000000517712002534" & @CRLF & _
" 865O 4898 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")