import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<hora>[0-9]{8})\\s(?<mix>\\d{3})(?<resp>[I|O])";
final String string = " 09523744 865O F010@@@@Y1905A46100000002 00000000151100157600STD20001\n"
+ " 865O 030202040005 1029 003047100000000012602 \n"
+ " 865O 00000000000000000000000000000000000000000000517712002534\n"
+ " 865O 4898 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}