package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<hora>[0-9]{8})\s(?<mix>\d{3})(?<resp>[I|O])`)
var str = ` 09523744 865O F010@@@@Y1905A46100000002 00000000151100157600STD20001
865O 030202040005 1029 003047100000000012602
865O 00000000000000000000000000000000000000000000517712002534
865O 4898 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}