use strict;
my $str = ' 09523744 865O F010@@@@Y1905A46100000002 00000000151100157600STD20001
865O 030202040005 1029 003047100000000012602
865O 00000000000000000000000000000000000000000000517712002534
865O 4898 ';
my $regex = qr/(?<hora>[0-9]{8})\s(?<mix>\d{3})(?<resp>[I|O])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}