# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\/([^\/]+)\/?$/$1/gm;t' <<< "http://www.xx.com/download/apple-Selection-products/beauty-soap-ICs/
http://www.XX.com/download/apple-Selection-products/beauty-soap-ICs"