package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*/([^/]+)/?$`)
var str = `http://www.xx.com/download/apple-Selection-products/beauty-soap-ICs/
http://www.XX.com/download/apple-Selection-products/beauty-soap-ICs`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}