using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*/([^/]+)/?$";
string substitution = @"$1";
string input = @"http://www.xx.com/download/apple-Selection-products/beauty-soap-ICs/
http://www.XX.com/download/apple-Selection-products/beauty-soap-ICs";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}