const regex = new RegExp('.*/([^/]+)/?$', 'gm')
const str = `http://www.xx.com/download/apple-Selection-products/beauty-soap-ICs/
http://www.XX.com/download/apple-Selection-products/beauty-soap-ICs`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);