re = /.*\/([^\/]+)\/?$/m
str = 'http://www.xx.com/download/apple-Selection-products/beauty-soap-ICs/
http://www.XX.com/download/apple-Selection-products/beauty-soap-ICs'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result