#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(www.)?ucwebapi(\-uccore\d{0,3}\-?\d{0,3})?\.testme\.net"
Local $sString = "ucwebapi.testme.net" & @CRLF & _
"ucwebapi-uccore.testme.net" & @CRLF & _
"ucwebapi-uccore1-0.testme.net" & @CRLF & _
"ucwebapi-uccore999-999.testme.net" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")