re = /(www.)?ucwebapi(\-uccore\d{0,3}\-?\d{0,3})?\.testme\.net/
str = 'ucwebapi.testme.net
ucwebapi-uccore.testme.net
ucwebapi-uccore1-0.testme.net
ucwebapi-uccore999-999.testme.net
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end