package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(www.)?ucwebapi(\-uccore\d{0,3}\-?\d{0,3})?\.testme\.net`)
var str = `ucwebapi.testme.net
ucwebapi-uccore.testme.net
ucwebapi-uccore1-0.testme.net
ucwebapi-uccore999-999.testme.net
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}