const regex = /(www.)?ucwebapi(\-uccore\d{0,3}\-?\d{0,3})?\.testme\.net/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(www.)?ucwebapi(\\-uccore\\d{0,3}\\-?\\d{0,3})?\\.testme\\.net', 'g')
const str = `ucwebapi.testme.net
ucwebapi-uccore.testme.net
ucwebapi-uccore1-0.testme.net
ucwebapi-uccore999-999.testme.net
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}