$re = '/(www.)?ucwebapi(\-uccore\d{0,3}\-?\d{0,3})?\.testme\.net/';
$str = 'ucwebapi.testme.net
ucwebapi-uccore.testme.net
ucwebapi-uccore1-0.testme.net
ucwebapi-uccore999-999.testme.net
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);