using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(www.)?ucwebapi(\-uccore\d{0,3}\-?\d{0,3})?\.testme\.net";
string input = @"ucwebapi.testme.net
ucwebapi-uccore.testme.net
ucwebapi-uccore1-0.testme.net
ucwebapi-uccore999-999.testme.net
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}