import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(www.)?ucwebapi(\\-uccore\\d{0,3}\\-?\\d{0,3})?\\.testme\\.net";
final String string = "ucwebapi.testme.net\n"
+ "ucwebapi-uccore.testme.net\n"
+ "ucwebapi-uccore1-0.testme.net\n"
+ "ucwebapi-uccore999-999.testme.net\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}